2.1.3 Klientgeräte

Zum 31.12.2017 entfällt der Support für Windows XP bzw. Windows Server 2003 R2 und darunter.
Um CPL24 bei Ihnen installieren zu können, müssen folgende Voraussetzungen erfüllt sein:
  • .NET Framework 4.5
  • aktuelle PowerShell
  • Ziel URL zum CPL24 RSaF Service
  • Windows Service Account mit dem Recht die Konfigurations-Ziele zu lesen
  • Daten auslesen von Active Directory
    • PowerShell Modul ActiveDirectory (RSAT)
    • Zugang zum Quell-Domain-Controller
  • Daten auslesen von Hyper-V
    • PowerShell Modul Virtual Machine Manager (SCVMM Setup)
    • Zugang zum Quell-SCVMM-Server
  • Daten auslesen von VMWare
    • PowerShell Snapin VMware.VimAutomation.Core (VMWare PowerCLISetup)
    • Zugang zum Quell-vSphere-Server

Achtung: Sie können die Verfügbarkeit der PowerShell-Anforderungen ganz leicht testen, indem Sie die Import-Module ActiveDirectory, Add-PSSnapin VMware.VimAutomation.Core oder Virtualmaschinemanager verwenden

Achtung: Wenn Sie bei VMWare Probleme haben, Daten zu bekommen, überprüfen Sie ob unter "Set-PowerCLIConfiguration" "InvalidCertificationAction Ignore" und "ProxyPolicy NoProxy" eingestellt ist

Achtung: Bitte prüfen Sie Ihre PowerShell-Version, indem sie eine Shell öffnen und "$psversiontable" eingeben. Das Ergebnis sollte in etwa so aussehen:
PSVersion
4.0
WSManStackVersion
3.0
SerializationVersion
1.1.0.1
CLRVersion
4.0.30319.18408
BuildVersion
6.3.9600.16406
PSCompatibleVersions
{1.0, 2.0, 3.0, 4.0}
PSRemotingProtocolVersion
2.2

Sie sollten mindestens eine PSVersion 3.0 und CLRVersion 3.0 besitzen. Falls nicht, verwenden Sie Windows SDK (KB2819745).

Achtung: Wenn Sie Fehler im ScriptAgent log, wie z. B. "Verwendung von .NET 2.0 Bestandteilen in einem .NET 4.0 Prozess" erhalten, bearbeiten Sie die ScriptAgent.exe.config Datei manuell, indem sie das folgende Attribut im Startup-Bereich einfügen:
<startup useLegacyV2RuntimeActivationPolicy="true">.
Mehr Informationen erhalten Sie hier [2] oder hier[1].

Wenn Sie die Standalone-Version unter Windows 2003/ XP laufen lassen wollen, benötigen Sie:

  • .NET Framework 4.0
  • KB968930 (PSVersion 2.0)